Firefox 3.0.11 – Probleme beim Setzen von Links mit TYPO3 RTE

Seit dem 4. Juni 2009 wird der Firefox in der Version 3.0.11 offiziell zum Download angeboten. Die neue Version schließt mehrere Sicherheitslücken uns soll ein weiteres Mal für mehr Stabilität sorgen. Viele Feuerfüchse werden sich seit diesem Tag automatisch aktualisiert haben. Für TYPO3-Redakteure und Adminstratoren hat sich der Tag der Aktualisierung teilweise als Nachteil erwiesen.

Wer das Update auf dern Firefox 3.0.11 bereits durchgeführt hat, wird festgestellt haben, dass die RTEhtmlarea seit diesem Tag nicht mehr in der gewohnten Art und Weise arbeitet. Beim Setzen eines Links durch den RTE wird dem eigentlichen Link „http://typo3“ vorangestellt. Umgehen kann man dieses Problem nur durch Handarbeit, indem man den Link im Quelltext-Modus des RTE setzt und speichert.

Die TYPO3-Community hat die Ursache für dieses Verhalten bereits lokalisiert und diskutiert verschiedene Patches für die Datei typo3/sysext/rtehtmlarea/htmlarea/plugins/TYPO3Link/typo3link.js im TYPO3 Bugtracker, Issue 11009. Am heutigen Vormittag wurden die Patches auf der TYPO3-Core Mailingliste zum Testen durch die Entwickler vorgestellt.

In den kommenden Version von TYPO3, 4.1.11, 4.2.7 und 4.3-beta1, wird das Problem also behoben sein. Wer nicht so lange warten möchte, sondern sein bestehendes TYPO3-System vorab patchen möchte, sollte sich noch so lange gedulden, bis im Bugtracker zu lesen ist, welcher Patch offiziell übernommen wurde. Unliebsame Überraschungen beim nächsten TYPO3-Update können sonst nämlich nicht ausgeschlossen werden.

Wer sich im TYPO3-Bugtracker nicht wohlfühlt, darf gerne regelmäßig auf diesem Beitrag zurückgreifen. Ich werde den endgültigen Patch an dieser Stelle bekannt geben.

Das Problem betrifft alle Webbrowser, die auf die Gecko Rendering Engine der Mozilla Foundation verwenden.

Update: Der Patch für TYPO3 4.1.11, 4.2.7 und Trunk steht fest und kann über den TYPO3 Bugtracker heruntergeladen werden, 0011009.patch und 0011009_4-1.patch.

Unbedingt beachten: Der Patch ist erst ab dem RTE 1.5.7 anwendbar.

Tags: , , ,

4 Kommentare zu “Firefox 3.0.11 – Probleme beim Setzen von Links mit TYPO3 RTE”

  1. peter

    Danke für die hilfreiche Information!

    Aus den Notes zum Bug, geht hervor, dass der Patch schon ins SVN aufgenommen worden ist:

    http://bugs.typo3.org/view.php?id=11009#c29079

    Aber leider Blick ich nicht ganz durch welcher. Wenn du in 2 Sätzen deppensicher beschreiben könntest, wie man das patcht, wär sicher vielen vorbeigooglenden geholfen! Danke! 🙂

  2. Patrick

    Mal eine Kurzanleitung für alle Lesefaulen des Bugtrackers, diese hat bei mir auf Anhieb funktioniert (für Version 4.2.6)

    – Auf den Seiten des Bugtrackers die Datei 0011009.patch laden (und am besten in eurem Typo3 Root-Verzeichnis kopieren)

    – Ein Backup der typo3link.js file Durchführen (typo3/sysext/rtehtmlarea/htmlarea/plugins/TYPO3Link/typo3link.js

    – denn Patch durchführen über
    patch -p0 < 0011009.patch

    – das typo3temp/rtehtmlarea Verzeichnis leeren
    rm -f typo3temp/rtehtmlarea/*

    – Den BE Cache in Eurem System leeren

    – Euren FF Browsercache leeren

    – den RTE Aufrufen

    Hat zumindest so auf unseren Servern ohne weitere Probleme funktioniert.

  3. Jan Loderhose

    @peter Patrick hat das ja schon übernommen 😉
    @Patrick Danke für die Anleitung!

    Wichtig zu wissen ist evtl. noch, dass 0011009.patch für TYPO3 4.2.x und 0011009_4-1.patch für TYPO3 4.1.x verwendet werden muss.

    Ansonsten Patricks Anleitung folgen. Der Patch für TYPO3 4.1.x erfolgt analog.

  4. RTE / Typo3-Patch installieren - TYPO3 Forum & Portal

    […] Firefox 3.0.11 – Probleme beim Setzen von Links mit TYPO3 RTE . TYPO3 . artif orange […]

Einen Kommentar schreiben

Sie müssen angemeldet sein, um kommentieren zu können.